[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v3 00/13] vbox: Improve handling of storage devices




On 11/07/2017 01:49 PM, Dawid Zamirski wrote:
> v2:
> https://www.redhat.com/archives/libvir-list/2017-October/msg01108.html
> 
> Changes since v2:
>  * Rebase on master
>  * Do not segfault in 'Cleanup partially-defined VM on failure' when
>    code jumps to cleanup and machine is NULL
>  * Take out SAS controller handling code into a separate patch
>  * Split up the snapshot function cleanup code into separate patches
>  * Fixed code formatting as pointed out in review
>  * Rename vboxDumpIDEHDDs -> vboxDumpDisks into a separate patch
>  * Add docs/news.xml patch to describe improvements/fixes in the series
> 
> Dawid Zamirski (13):
>   vbox: Cleanup partially-defined VM on failure
>   vbox: Process <controller> element in domain XML
>   vbox: Add vboxDumpStorageControllers
>   vbox: Rename vboxDumpIDEHDDs to vboxDumpDisks
>   vbox: Cleanup/prepare snasphot dumpxml functions
>   vbox: Do not free disk definitions on cleanup
>   vbox: Swap vboxSnapshotGetReadOnlyDisks arguments
>   vbox: Correctly generate drive name in dumpxml
>   vbox: Cleanup vboxDumpDisks implementation
>   vbox: Process empty removable disks in dumpxml
>   vbox: Generate disk address element in dumpxml
>   vbox: Add SAS controller support
>   docs: Update news.xml with vbox changes.
> 
>  docs/news.xml          |   74 ++++
>  src/vbox/vbox_common.c | 1105 +++++++++++++++++++++++++++++++-----------------
>  src/vbox/vbox_common.h |    8 +
>  3 files changed, 792 insertions(+), 395 deletions(-)
> 

I noted a couple of things along the way - one is something perhaps for
later and the other I fixed up...

Reviewed-by: John Ferlan <jferlan redhat com>
(series)

... and will push in a little while...

Tks,

John


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]