[libvirt] libvirt not wanting to read back its own interface XML

Michal Privoznik mprivozn at redhat.com
Thu Oct 19 09:52:34 UTC 2017

On 10/18/2017 04:48 PM, Marc Haber wrote:
> Hi,
> I'm trying to give libvirt knowlegde of a VLAN interface that is
> configured by a different means and not by libvirt. To figure out the
> syntax, I created a VLAN interface through virt-manager and dumped out
> the XML:
> <interface type='vlan' name='ens3.180'>
>   <protocol family='ipv6'>
>     <ip address='2a01:4f8:150:436c::55:100' prefix='64'/>
>     <ip address='fe80::5054:ff:fe30:e0d1' prefix='64'/>
>   </protocol>
>   <link speed='4294967295' state='up'/>
>   <vlan tag='180'>
>     <interface name='ens3'/>
>   </vlan>
> </interface>
> I then removed the Interface in virt-manager and tried to have libvirt
> read back its own XML.
> [12/784]mh at testsid85:~ $ virsh iface-dumpxml ens3.180 > ens3.180.xml
> [13/785]mh at testsid85:~ $ virsh iface-define ens3.180.xml
> error: Failed to define interface from ens3.180.xml
> error: XML error: could not get interface XML description: XML invalid - Expecting an element start, got nothing
> What is going on here? How do I define a VLAN interface via XML?

This is weird. However, I'm unable to reproduce with the latest libvirt.
What's your version? Have you tried the latest one?


More information about the libvir-list mailing list