[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 7/8] qemu: monitor: Rename 'device' argument for block job control APIs

On 08/15/2018 07:52 AM, Peter Krempa wrote:
> Starting from qemu 2.7 the 'device' argument is in fact a name of the
> job itself. Change our APIs accordingly and adjust the error message.
> Signed-off-by: Peter Krempa <pkrempa redhat com>
> ---
>  src/qemu/qemu_monitor.c      | 18 +++++++++---------
>  src/qemu/qemu_monitor.h      |  6 +++---
>  src/qemu/qemu_monitor_json.c | 22 +++++++++++-----------
>  src/qemu/qemu_monitor_json.h |  6 +++---
>  4 files changed, 26 insertions(+), 26 deletions(-)

Really, bizarre... The 'git am' of this series changed the
qemuMonitorJSONBlockJobError in qemuMonitorJSONBlockStream to pass
@jobname instead of @device, *BUT* that is not changed here.  Very,
very, odd git am behaviour.  Too many closely named functions too close
together is my guess for the pattern match.

What's in the patch is fine, just was confusing when my build failed!

Reviewed-by: John Ferlan <jferlan redhat com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]