[libvirt] [PATCH v2 4/6] travis: Rename DOCKER_CMD to LINUX_CMD

Andrea Bolognani abologna at redhat.com
Thu Jun 14 16:53:37 UTC 2018


The new name is arguably more informative, especially now
that we have MACOS_CMD and knowing that MINGW_CMD will
be introduced later on.

We still use DOCKER_CMD when calling Docker, and we assign
the actual script on a per-image basis. Having this
separation will help us when we introduce MinGW builds.

Signed-off-by: Andrea Bolognani <abologna at redhat.com>
---
 .travis.yml | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/.travis.yml b/.travis.yml
index ec45d78303..a902d203ff 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -12,11 +12,13 @@ matrix:
       env:
         - IMAGE=ubuntu:18.04
         - DISTCHECK_CONFIGURE_FLAGS="--with-init-script=systemd"
+        - DOCKER_CMD="$LINUX_CMD"
     - services:
         - docker
       env:
         - IMAGE=ubuntu:16.04
         - DISTCHECK_CONFIGURE_FLAGS="--with-init-script=upstart"
+        - DOCKER_CMD="$LINUX_CMD"
     - compiler: clang
       language: c
       os: osx
@@ -42,7 +44,7 @@ git:
 env:
   global:
     - VIR_TEST_DEBUG=1
-    - DOCKER_CMD="
+    - LINUX_CMD="
         apt-get update &&
         apt-get install -y \$PACKAGES &&
         ./autogen.sh &&
-- 
2.17.1




More information about the libvir-list mailing list