[PATCH 2/5] virDomainCheckpointDefParse: Use 'unsigned int' for flags

Peter Krempa pkrempa at redhat.com
Wed Dec 2 14:13:11 UTC 2020


Fix the type for a variable holding flags to the usual 'unsigned int'
and change the name to be more appropriate to it's use.

Signed-off-by: Peter Krempa <pkrempa at redhat.com>
---
 src/conf/checkpoint_conf.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/conf/checkpoint_conf.c b/src/conf/checkpoint_conf.c
index 33b6699be7..8744ac83e1 100644
--- a/src/conf/checkpoint_conf.c
+++ b/src/conf/checkpoint_conf.c
@@ -157,12 +157,12 @@ virDomainCheckpointDefParse(xmlXPathContextPtr ctxt,
         def->parent.parent_name = virXPathString("string(./parent/name)", ctxt);

         if ((domainNode = virXPathNode("./domain", ctxt))) {
-            int domainflags = VIR_DOMAIN_DEF_PARSE_INACTIVE |
-                              VIR_DOMAIN_DEF_PARSE_SKIP_VALIDATE;
+            unsigned int domainParseFlags = VIR_DOMAIN_DEF_PARSE_INACTIVE |
+                                            VIR_DOMAIN_DEF_PARSE_SKIP_VALIDATE;

             def->parent.dom = virDomainDefParseNode(ctxt->node->doc, domainNode,
                                                     xmlopt, parseOpaque,
-                                                    domainflags);
+                                                    domainParseFlags);
             if (!def->parent.dom)
                 return NULL;
         } else {
-- 
2.28.0




More information about the libvir-list mailing list