[PATCH 2/3] lib: s/free-page-reporting/free_page_reporting/
mprivozn at redhat.com
Thu Oct 15 08:36:48 UTC 2020
On 10/15/20 8:03 AM, Erik Skultety wrote:
> On Wed, Oct 14, 2020 at 05:29:33PM +0200, Michal Privoznik wrote:
>> In fee8a61d29 a new attribute to <memballoon/> was introduced:
>> free-page-reporting. We don't really like hyphens in attribute
>> names. Use underscores instead.
> Disclaimer: I just noticed this by accident, I'm sure I've missed several other
> cases in the past half a year at least, nevertheless, I'll comment here.
> Back when we added support for SEV I remember being asked to rename the
> underscored name to a camel case one as apparently at that time we were trying
> to standardize on it and so I did change it. Back to the present, we're still
> not consistent with this, so I'd like to propose we either let this in
> or we switch to camelcase and update the code-style page with a new paragraph
> under the naming convention dealing with XML attributes regardless.
Fair enough. Dan, I hope your Reviewed-by stands if I do the change to
camelCase locally without sending v2?
I'll post the code-style change as a separate patch.
More information about the libvir-list