[PATCH v5] docs/deprecated: deprecate passing plugin args through `arg=`

Mahmoud Mandour ma.mandourr at gmail.com
Mon Aug 2 13:44:14 UTC 2021

Signed-off-by: Mahmoud Mandour <ma.mandourr at gmail.com>

v4 -> v5:
    1. Mentioned that short-form booleans are still usable but not preferable.

 docs/system/deprecated.rst | 10 ++++++++++
 1 file changed, 10 insertions(+)

diff --git a/docs/system/deprecated.rst b/docs/system/deprecated.rst
index e2e0090878..43ae154c85 100644
--- a/docs/system/deprecated.rst
+++ b/docs/system/deprecated.rst
@@ -126,6 +126,16 @@ other options have been processed.  This will either have no effect (if
 if they were not given.  The property is therefore useless and should not be
+Plugin argument passing through ``arg=<string>`` (since 6.1)
+Passing TCG plugins arguments through ``arg=`` is redundant is makes the
+command-line less readable, especially when the argument itself consist of a
+name and a value, e.g. ``-plugin plugin_name,arg="arg_name=arg_value"``.
+Therefore, the usage of ``arg`` is redundant. Single-word arguments are treated
+as short-form boolean values, and passed to plugins as ``arg_name=on``.
+However, short-form booleans are deprecated and full explicit ``arg_name=on``
+form is preferred.
 QEMU Machine Protocol (QMP) commands

More information about the libvir-list mailing list