[libvirt PATCH 13/17] util: extract virStorageFile code into storage_file

Peter Krempa pkrempa at redhat.com
Thu Jan 7 13:52:22 UTC 2021

On Thu, Jan 07, 2021 at 14:17:04 +0100, Pavel Hrdina wrote:
> On Mon, Jan 04, 2021 at 05:43:32PM +0100, Peter Krempa wrote:
> > On Mon, Dec 14, 2020 at 16:55:33 +0100, Pavel Hrdina wrote:


> Thanks for the explanation for what the functions are used but it
> doesn't make it clear to me where they should be placed.
> > The naming mismatch comes from the years this code was gradually
> > modified and I'd really prefer if everything unifies on virStorageSource
> > since everything is actually related to virStorageSource.
> > 
> > For the backends which do the actual access of storage we could rename
> > it to virStorageSourceBackend.
> Sounds good to match the naming of functions to the structure that it
> operates with but I'm afraid that it will make more confusion in the
> future if someone tries to add a new functionality into the
> virStorageSource code, especially if the conf or storage_file place
> should be used.

This should actually go well with the proposed rename.
'virStorageSourceConf' can become a structure dealing with just the XML
bits, and it will be included in 'virStorageSource' which will house
other stuff.

More information about the libvir-list mailing list