[PATCH 1/4] capabilities: Rename siblings to distances
mprivozn at redhat.com
Mon May 24 12:12:56 UTC 2021
On 5/21/21 9:46 AM, Peter Krempa wrote:
> On Thu, May 20, 2021 at 17:24:53 +0200, Michal Privoznik wrote:
>> The virCapsHostNUMACellSiblingInfo structure really represents
>> distance to other NUMA node. Rename the structure and variables
>> of that type to make it more obvious.
>> Signed-off-by: Michal Privoznik <mprivozn at redhat.com>
>> src/conf/capabilities.c | 52 +++++++++++++++++-----------------
>> src/conf/capabilities.h | 10 +++----
>> src/conf/virconftypes.h | 2 +-
>> src/libxl/libxl_capabilities.c | 20 ++++++-------
>> 4 files changed, 42 insertions(+), 42 deletions(-)
> I first wanted to complain that we might want to add other data related
> to NUMA siblings other than distances ...
That was my intent when implementing NUMA distance reporting for
capabilities, years ago. And I'm planning on extending capabilities for
memory caches reporting (currently struct _virDomainNumaCache for domain
NUMA nodes). But my code has it as another argument to
virCapabilitiesHostNUMAAddCell() and another struct (I'm doing a
deduplication similar to this one).
And because of that code reuse (well, XML formater) - I prefer to follow
_virDomainNuma struct in capabilities.
More information about the libvir-list