Hello guys,<br><br>To finish the libvirt compilation, I've commented:<br><br>file: libvirt/configure:<br>#elif test "z$with_libxml" = "z" -a "z$PKG_CONFIG_ENABLED" = "zyes" ; then
<br>#    PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_MIN_VERSION,<br>#       LIBXML_FOUND=yes,<br>#       LIBXML_FOUND=no)<br><br>I know that the libxml in my system is in correct version. the var
LIBXML_MIN_VERSION in configure script is set to "2.5.0". This is the
version in my system:<br>
# dpkg -l | grep libxml2<br>
ii  libxml2                2.6.27.dfsg-1                   GNOME XML library<br>
ii  libxml2-dev            2.6.27.dfsg-1                   Development files for the GNOME XML library<br>
<br>file: libvirt/tests/xencapstest.c<br>  /*  if (!(actualxml = xenHypervisorMakeCapabilitiesXML(NULL, hostmachine, fp1, fp2)))<br>      goto fail;*/<br><br>In libvirt/tests/xencapstest.c, I don't know if comment it is correct. 
<br>Any idea? I do it correctly? this test is important to libvirt?<br><br>This is the return error if I not comment the conditional 'if' in libvirt/tests/xencapstest.c:<br><br>gcc -fno-stack-protector -o xencapstest 
xencapstest.o testutils.o ../src/.libs/libvirt_la-conf.o ../src/.libs/libvirt_la-hash.o ../src/.libs/libvirt_la-libvirt.o ../src/.libs/libvirt_la-proxy_internal.o ../src/.libs/libvirt_la-qemu_internal.o ../src/.libs/libvirt_la-
sexpr.o ../src/.libs/libvirt_la-test.o ../src/.libs/libvirt_la-virterror.o ../src/.libs/libvirt_la-xend_internal.o ../src/.libs/libvirt_la-xen_internal.o ../src/.libs/libvirt_la-xen_unified.o ../src/.libs/libvirt_la-xm_internal.o ../src/.libs/libvirt_la-
xml.o ../src/.libs/libvirt_la-xs_internal.o  -L/usr/lib /usr/lib/libxml2.so<br>xencapstest.o: In function `testCompareFiles':<br>xencapstest.c:(.text+0xb4): undefined reference to `xenHypervisorMakeCapabilitiesXML'
<br>collect2: ld returned 1 exit status<br>make[3]: ** [xencapstest] Erro 1<br><br><br>regards<br><br><br><div><span class="gmail_quote">On 5/5/07, <b class="gmail_sendername">Marco Sinhoreli</b> <<a href="mailto:msinhore@gmail.com">
msinhore@gmail.com</a>> wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Hello Richard,<br><br>I tried with debian do it. In command 
autogen.sh return it:<br><br>$ ./autogen.sh --prefix=/usr/local --enable-compile-warnings=error --enable-debug=yes<br>[...]<br>./configure: line 20698: syntax error near unexpected token `LIBXML,'
<br>./configure: line 20698: `    PKG_CHECK_MODULES(LIBXML, libxml-2.0 >= $LIBXML_MIN_VERSION,'<br><br>I read the 'configure' shell script code and in release 0.1.11 the libxml section is different. I know that if I comment this entry I run this scrtipt without errors but it isn't elegant :-)
<br><br>Thanks Richard,<br><br>regards<div><span class="e" id="q_1125c51660be19ba_1"><br><br><div><span class="gmail_quote">On 5/5/07, <b class="gmail_sendername">Richard W.M. Jones</b> <<a href="mailto:rjones@redhat.com" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
rjones@redhat.com</a>> wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Marco Sinhoreli wrote:<br>> Hello list,<br>><br>> I'm writing a how-to about libvirt compilation in Debian Etch. Well, I<br>> tried to compile version 0.1.11 in a Debian etch completly newly built<br>> from debootstrap. These are the steps that I took:
<br>> ----- init commands<br>> apt-get install make gcc<br>> # cd /usr/src && wget<br>> <a href="http://libvirt.org/sources/libvirt-cvs-snapshot.tar.gz" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
http://libvirt.org/sources/libvirt-cvs-snapshot.tar.gz
</a> && tar -xzvf<br>> libvirt-cvs-snapshot.tar.gz<br>> # cd libvirt-0.1.11<br><br>It looks like CVS snapshots aren't being updated!  The one on the site<br>at the moment dates from 2007-02-14 and as you found out contains
<br>libvirt-0.1.11, which is ancient history.  I'll ask Daniel Veillard<br>about that one next week.<br><br>I also tried building libvirt on Debian and didn't get very far either.<br>  But we're committed to making libvirt work on Debian (and Ubuntu, and
<br>other free OSes for that matter).<br><br>So if you have the time can you try this to get the latest CVS version:<br><br># apt-get install cvs gcc make gettext automake1.9<br><br>$ cvs -d ':<a href="http://pserver:anoncvs@libvirt.org:2401/data/cvs" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">

pserver:anoncvs@libvirt.org:2401/data/cvs</a>' co login<br>   # at the prompt type anoncvs<br><br>$ cvs -d ':<a href="http://pserver:anoncvs@libvirt.org:2401/data/cvs" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">
pserver:anoncvs@libvirt.org:2401/data/cvs</a>
' co libvirt<br>   # the above will check out the source into a subdir called libvirt<br><br>$ cd libvirt<br><br>$ ./autogen.sh --prefix=$HOME/local --enable-compile-warnings=error<br>--enable-debug=yes<br>   # you can change the --prefix to something more useful
<br><br>If the above succeeds -- and it didn't for me -- then:<br><br>$ make<br><br>If any of the steps fail then post the full output.  I can look at why<br>libvirt on Debian is failing next week.<br><br>Thanks for helping with libvirt,
<br><br>Rich.<br><br>--<br>Emerging Technologies, Red Hat  <a href="http://et.redhat.com/%7Erjones/" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">http://et.redhat.com/~rjones/</a><br>64 Baker Street, London, W1U 7DF     Mobile: +44 7866 314 421
<br><br>Registered Address: Red Hat UK Ltd, Amberley Place, 107-111 Peascod
<br>Street, Windsor, Berkshire, SL4 1TE, United Kingdom.<br>Registered in England and Wales under Company Registration No. 3798903<br>Directors: Michael Cunningham (USA), Charlie Peters (USA) and David<br>Owens (Ireland)
<br>
<br></blockquote></div><br><br clear="all"><br></span></div>-- <br><span class="sg">Marco Sinhoreli
</span></blockquote></div><br><br>