[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-announce] Entering freeze for libvirt-2.4.0



   As planned I just tagged the release in git and pushed signed tarball
and rpms to the usual place:

    ftp://libvirt.org/libvirt/

  Not in my normal environment this week so I hadn't had a chance to test
the build before pushing, sorry about this but things went smoothly, I noticed
a warning in virsh however:

  CC       virsh-virsh-host.o
vsh.c: In function 'vshReadlineParse':
vsh.c:516:9: warning: 'opts_need_arg' may be used uninitialized in this function [-Wmaybe-uninitialized]
     i = ffsl(*opts_need_arg) - 1;
         ^~~~~~~~~~~~~~~~~~~~
vsh.c:2658:14: note: 'opts_need_arg' was declared here
     uint64_t opts_need_arg, opts_seen;
              ^~~~~~~~~~~~~

  that probably ought to be fixed for release.
I hope to be able to push RC2 during the week-end and possibly the final 2.4.0
on the 1st Nov if all goes well.

   please give it some testing,

     thanks !

Daniel

 

-- 
Daniel Veillard      | Open Source and Standards, Red Hat
veillard redhat com  | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]