[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-tck-mas ter-rpm » libvirt-fedora-25 #463



See <https://ci.centos.org/job/libvirt-tck-master-rpm/systems=libvirt-fedora-25/463/display/redirect>

------------------------------------------
Started by upstream project "libvirt-tck-master-rpm" build number 463
originally caused by:
 Started by upstream project "libvirt-tck-master-test" build number 467
 originally caused by:
  Started by user Libvirt
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-fedora-25 (libvirt) in workspace <https://ci.centos.org/job/libvirt-tck-master-rpm/systems=libvirt-fedora-25/ws/>
[libvirt-tck-master] $ /bin/sh -xe /tmp/hudson5805890841394827541.sh
+ sed -i -e 's/BuildRequires: *perl-Sys-Virt.*//' perl-Sys-Virt-TCK.spec
+ sed -i -e 's/BuildRequires: *perl(Sys::Virt).*//' perl-Sys-Virt-TCK.spec
+ sed -i -e 's/BuildRequires: *libvirt.*devel.*//' perl-Sys-Virt-TCK.spec
+ rm -f '*.tar.gz'
+ perl Build dist

IMPORTANT NOTE: The 'passthrough' style of Makefile.PL is deprecated and
may be removed in a future version of Module::Build in favor of the
'configure_requires' property.  See Module::Build::Compat
documentation for details.

Module::Build was not found in configure_requires! Adding it now
automatically as: configure_requires => { 'Module::Build' => 0.42 }
Creating Makefile.PL
Created META.yml and META.json
Creating Sys-Virt-TCK-v0.1.0
Creating Sys-Virt-TCK-v0.1.0.tar.gz
+ rpmbuild -ta Sys-Virt-TCK-v0.1.0.tar.gz
error: Failed build dependencies:
	perl(Config::Record) is needed by perl-Sys-Virt-TCK-0.1.0-1.noarch
	perl(Sub::Uplevel) is needed by perl-Sys-Virt-TCK-0.1.0-1.noarch
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]