[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-perl-ma ster-test » libvirt-fedora-rawhide #296



See <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-fedora-rawhide/296/display/redirect>

------------------------------------------
Started by upstream project "libvirt-perl-master-test" build number 296
originally caused by:
 Started by upstream project "libvirt-perl-master-build" build number 316
 originally caused by:
  Started by upstream project "libvirt-master-build" build number 426
  originally caused by:
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-fedora-rawhide (libvirt) in workspace <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-fedora-rawhide/ws/>
[libvirt-perl-master] $ /bin/sh -xe /tmp/hudson4239440270900264735.sh
+ make -j3 test TEST_MAINTAINER=1
"/usr/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- Virt.bs blib/arch/auto/Sys/Virt/Virt.bs 644
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/005-pod.t ............ ok
t/010-pod-coverage.t ... ok
t/015-changes.t ........ ok
t/020-constants.t ...... ok

#   Failed test 'virConnectDomainEventBlockThresholdCallback'
#   at t/030-api-coverage.t line 155.

#   Failed test 'virDomainSetBlockThreshold'
#   at t/030-api-coverage.t line 155.

#   Failed test 'VIR_DOMAIN_EVENT_ID_BLOCK_THRESHOLD'
#   at t/030-api-coverage.t line 169.

#   Failed test 'VIR_MIGRATE_TLS'
#   at t/030-api-coverage.t line 169.
# Looks like you failed 4 tests of 1563.
t/030-api-coverage.t ... 
Dubious, test returned 4 (wstat 1024, 0x400)
Failed 4/1563 subtests 
t/100-connect.t ........ ok
t/200-domains.t ........ ok
t/300-networks.t ....... ok
t/400-storage-pools.t .. ok
t/500-storage-vols.t ... ok
t/600-interfaces.t ..... ok
t/800-events.t ......... ok

Test Summary Report
-------------------
t/030-api-coverage.t (Wstat: 1024 Tests: 1563 Failed: 4)
  Failed tests:  13, 240, 686, 1207
  Non-zero exit status: 4
Files=12, Tests=1815, 22 wallclock secs ( 0.44 usr  0.19 sys +  7.52 cusr  1.65 csys =  9.80 CPU)
Result: FAIL
Failed 1/12 test programs. 4/1815 subtests failed.
make: *** [Makefile:1018: test_dynamic] Error 255
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]