[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-perl-ma ster-test » libvirt-freebsd-10 #918



See <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-freebsd-10/918/display/redirect>

------------------------------------------
Started by upstream project "libvirt-perl-master-test" build number 918
originally caused by:
 Started by upstream project "libvirt-perl-master-build" build number 942
 originally caused by:
  Started by upstream project "libvirt-master-build" build number 1170
  originally caused by:
   Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-freebsd-10 (libvirt) in workspace <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-freebsd-10/ws/>
[libvirt-perl-master] $ /bin/sh -xe /tmp/jenkins1289659652681354300.sh
+ MAKE=make
+ uname
+ unamestr=FreeBSD
+ [ FreeBSD = FreeBSD ]
+ MAKE=gmake
+ export PATH=/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/home/jenkins/bin
+ gmake -j3 test TEST_MAINTAINER=1
"/usr/local/bin/perl5.24.3" -MExtUtils::Command::MM -e 'cp_nonempty' -- Virt.bs blib/arch/auto/Sys/Virt/Virt.bs 644
PERL_DL_NONLAZY=1 "/usr/local/bin/perl5.24.3" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/005-pod.t ............ ok
t/010-pod-coverage.t ... ok
t/015-changes.t ........ ok
t/020-constants.t ...... ok

#   Failed test 'virStoragePoolLookupByTargetPath'
#   at t/030-api-coverage.t line 159.
# Looks like you failed 1 test of 1612.
t/030-api-coverage.t ... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1612 subtests 
t/100-connect.t ........ ok
t/200-domains.t ........ ok
t/300-networks.t ....... ok
t/400-storage-pools.t .. ok
t/500-storage-vols.t ... ok
t/600-interfaces.t ..... ok
t/800-events.t ......... ok

Test Summary Report
-------------------
t/030-api-coverage.t (Wstat: 256 Tests: 1612 Failed: 1)
  Failed test:  428
  Non-zero exit status: 1
Files=12, Tests=1864, 40 wallclock secs ( 1.26 usr  0.30 sys + 19.63 cusr  2.91 csys = 24.10 CPU)
Result: FAIL
Failed 1/12 test programs. 1/1864 subtests failed.
gmake: *** [Makefile:1017: test_dynamic] Error 255
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]