[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-perl-ma ster-test » libvirt-debian-8 #919



See <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-debian-8/919/display/redirect>

------------------------------------------
Started by upstream project "libvirt-perl-master-test" build number 919
originally caused by:
 Started by upstream project "libvirt-perl-master-build" build number 943
 originally caused by:
  Started by upstream project "libvirt-master-build" build number 1171
  originally caused by:
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-debian-8 (libvirt) in workspace <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-debian-8/ws/>
[libvirt-perl-master] $ /bin/sh -xe /tmp/jenkins3494564189463601764.sh
+ MAKE=make
+ uname
+ unamestr=Linux
+ [ Linux = FreeBSD ]
+ export PATH=/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
+ make -j3 test TEST_MAINTAINER=1
PERL_DL_NONLAZY=1 PERL_USE_UNSAFE_INC=1 /usr/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/005-pod.t ............ ok
t/010-pod-coverage.t ... ok
t/015-changes.t ........ ok
t/020-constants.t ...... ok

#   Failed test 'virStoragePoolLookupByTargetPath'
#   at t/030-api-coverage.t line 159.
# Looks like you failed 1 test of 1612.
t/030-api-coverage.t ... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1612 subtests 
t/100-connect.t ........ ok
t/200-domains.t ........ ok
t/300-networks.t ....... ok
t/400-storage-pools.t .. ok
t/500-storage-vols.t ... ok
t/600-interfaces.t ..... ok
t/800-events.t ......... ok

Test Summary Report
-------------------
t/030-api-coverage.t (Wstat: 256 Tests: 1612 Failed: 1)
  Failed test:  428
  Non-zero exit status: 1
Files=12, Tests=1864, 19 wallclock secs ( 0.90 usr  0.08 sys + 12.62 cusr  0.62 csys = 14.22 CPU)
Result: FAIL
Failed 1/12 test programs. 1/1864 subtests failed.
Makefile:1004: recipe for target 'test_dynamic' failed
make: *** [test_dynamic] Error 255
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]