[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-perl-ma ster-test » libvirt-centos-6 #919



See <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-centos-6/919/display/redirect>

------------------------------------------
Started by upstream project "libvirt-perl-master-test" build number 919
originally caused by:
 Started by upstream project "libvirt-perl-master-build" build number 943
 originally caused by:
  Started by upstream project "libvirt-master-build" build number 1171
  originally caused by:
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
   Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-centos-6 (libvirt) in workspace <https://ci.centos.org/job/libvirt-perl-master-test/systems=libvirt-centos-6/ws/>
[libvirt-perl-master] $ /bin/sh -xe /tmp/jenkins6059655044402472320.sh
+ MAKE=make
++ uname
+ unamestr=Linux
+ '[' Linux = FreeBSD ']'
+ export PATH=/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jenkins/bin
+ PATH=/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/home/jenkins/build/libvirt/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jenkins/bin
+ make -j3 test TEST_MAINTAINER=1
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/005-pod.t ............ ok
t/010-pod-coverage.t ... ok
t/015-changes.t ........ skipped: Test::CPAN::Changes required for this test
t/020-constants.t ...... ok

#   Failed test 'virStoragePoolLookupByTargetPath'
#   at t/030-api-coverage.t line 159.
# Looks like you failed 1 test of 1612.
t/030-api-coverage.t ... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1612 subtests 
t/100-connect.t ........ ok
t/200-domains.t ........ ok
t/300-networks.t ....... ok
t/400-storage-pools.t .. ok
t/500-storage-vols.t ... ok
t/600-interfaces.t ..... ok
t/800-events.t ......... ok

Test Summary Report
-------------------
t/030-api-coverage.t (Wstat: 256 Tests: 1612 Failed: 1)
  Failed test:  428
  Non-zero exit status: 1
Files=12, Tests=1860, 42 wallclock secs ( 1.11 usr  0.15 sys + 16.51 cusr  0.72 csys = 18.49 CPU)
Result: FAIL
Failed 1/12 test programs. 1/1860 subtests failed.
make: *** [test_dynamic] Error 255
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]