[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-go-mast er-check » libvirt-freebsd-10 #1118



See <https://ci.centos.org/job/libvirt-go-master-check/systems=libvirt-freebsd-10/1118/display/redirect>

------------------------------------------
Started by upstream project "libvirt-go-master-check" build number 1118
originally caused by:
 Started by upstream project "libvirt-go-master-build" build number 1129
 originally caused by:
  Started by upstream project "libvirt-master-build" build number 1528
  originally caused by:
   Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-freebsd-10 (libvirt) in workspace <https://ci.centos.org/job/libvirt-go-master-check/systems=libvirt-freebsd-10/ws/>
[libvirt-go-master] $ /bin/sh -xe /tmp/jenkins566479566649033411.sh
+ export 'TEST_ARGS=-tags api'
+ go test -tags api
Missing function 'virDomainGetLaunchSecurityInfo'
Missing function 'virNodeGetSEVInfo'
Missing macro 'VIR_DOMAIN_LAUNCH_SECURITY_SEV_MEASUREMENT'
Missing macro 'VIR_NODE_SEV_CBITPOS'
Missing macro 'VIR_NODE_SEV_CERT_CHAIN'
Missing macro 'VIR_NODE_SEV_PDH'
Missing macro 'VIR_NODE_SEV_REDUCED_PHYS_BITS'
--- FAIL: TestAPICoverage (0.56s)
panic: Missing symbols found [recovered]
	panic: Missing symbols found

goroutine 19 [running]:
testing.tRunner.func1(0xc4200cc0f0)
	/usr/local/go/src/testing/testing.go:742 +0x29d
panic(0x5ae800, 0x611a90)
	/usr/local/go/src/runtime/panic.go:502 +0x229
_/usr<https://ci.centos.org/job/libvirt-go-master-check/systems=libvirt-freebsd-10/ws/.TestAPICoverage(0xc4200cc0f0)>
	/usr<https://ci.centos.org/job/libvirt-go-master-check/systems=libvirt-freebsd-10/ws/api_test.go>:506 +0x548
testing.tRunner(0xc4200cc0f0, 0x5fcce0)
	/usr/local/go/src/testing/testing.go:777 +0xd0
created by testing.(*T).Run
	/usr/local/go/src/testing/testing.go:824 +0x2e0
exit status 2
FAIL	_/usr<https://ci.centos.org/job/libvirt-go-master-check/systems=libvirt-freebsd-10/ws/>	0.689s
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]