[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-go-chec k » libvirt-fedora-29 #483



See <https://ci.centos.org/job/libvirt-go-check/systems=libvirt-fedora-29/483/display/redirect>

------------------------------------------
Started by upstream project "libvirt-go-check" build number 483
originally caused by:
 Started by upstream project "libvirt-go-build" build number 489
 originally caused by:
  Started by upstream project "libvirt-build" build number 584
  originally caused by:
   Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-fedora-29 (libvirt) in workspace <https://ci.centos.org/job/libvirt-go-check/systems=libvirt-fedora-29/ws/>
[libvirt-go] $ /bin/sh -xe /tmp/jenkins4589835449079111634.sh
+ export 'TEST_ARGS=-tags api'
+ TEST_ARGS='-tags api'
+ go test -tags api
Missing function 'virNetworkListAllPorts'
Missing function 'virNetworkPortCreateXML'
Missing function 'virNetworkPortDelete'
Missing function 'virNetworkPortFree'
Missing function 'virNetworkPortGetNetwork'
Missing function 'virNetworkPortGetParameters'
Missing function 'virNetworkPortGetUUID'
Missing function 'virNetworkPortGetUUIDString'
Missing function 'virNetworkPortGetXMLDesc'
Missing function 'virNetworkPortLookupByUUID'
Missing function 'virNetworkPortLookupByUUIDString'
Missing function 'virNetworkPortSetParameters'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_AVERAGE'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_BURST'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_FLOOR'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_PEAK'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_OUT_AVERAGE'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_OUT_BURST'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_OUT_PEAK'
Missing enum 'VIR_ERR_INVALID_NETWORK_PORT'
Missing enum 'VIR_ERR_NETWORK_PORT_EXIST'
Missing enum 'VIR_ERR_NO_NETWORK_PORT'
Missing enum 'VIR_NETWORK_PORT_CREATE_RECLAIM'
--- FAIL: TestAPICoverage (0.60s)
panic: Missing symbols found [recovered]
	panic: Missing symbols found

goroutine 19 [running]:
testing.tRunner.func1(0xc0000c2100)
	/usr/lib/golang/src/testing/testing.go:792 +0x387
panic(0x5ccaa0, 0x639ca0)
	/usr/lib/golang/src/runtime/panic.go:513 +0x1b9
_<https://ci.centos.org/job/libvirt-go-check/systems=libvirt-fedora-29/ws/.TestAPICoverage(0xc0000c2100)>
	<https://ci.centos.org/job/libvirt-go-check/systems=libvirt-fedora-29/ws/api_test.go>:501 +0x554
testing.tRunner(0xc0000c2100, 0x61b108)
	/usr/lib/golang/src/testing/testing.go:827 +0xbf
created by testing.(*T).Run
	/usr/lib/golang/src/testing/testing.go:878 +0x35c
exit status 2
FAIL	_<https://ci.centos.org/job/libvirt-go-check/systems=libvirt-fedora-29/ws/>	0.843s
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]