[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Libvirt-ci] Build failed in Jenkins: libvirt-go-chec k » libvirt-debian-9 #483



See <https://ci.centos.org/job/libvirt-go-check/systems=libvirt-debian-9/483/display/redirect>

------------------------------------------
Started by upstream project "libvirt-go-check" build number 483
originally caused by:
 Started by upstream project "libvirt-go-build" build number 489
 originally caused by:
  Started by upstream project "libvirt-build" build number 584
  originally caused by:
   Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on libvirt-debian-9 (libvirt) in workspace <https://ci.centos.org/job/libvirt-go-check/systems=libvirt-debian-9/ws/>
[libvirt-go] $ /bin/sh -xe /tmp/jenkins2805918341200187088.sh
+ export TEST_ARGS=-tags api
+ go test -tags api
Missing function 'virNetworkListAllPorts'
Missing function 'virNetworkPortCreateXML'
Missing function 'virNetworkPortDelete'
Missing function 'virNetworkPortFree'
Missing function 'virNetworkPortGetNetwork'
Missing function 'virNetworkPortGetParameters'
Missing function 'virNetworkPortGetUUID'
Missing function 'virNetworkPortGetUUIDString'
Missing function 'virNetworkPortGetXMLDesc'
Missing function 'virNetworkPortLookupByUUID'
Missing function 'virNetworkPortLookupByUUIDString'
Missing function 'virNetworkPortSetParameters'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_AVERAGE'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_BURST'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_FLOOR'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_IN_PEAK'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_OUT_AVERAGE'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_OUT_BURST'
Missing macro 'VIR_NETWORK_PORT_BANDWIDTH_OUT_PEAK'
Missing enum 'VIR_ERR_INVALID_NETWORK_PORT'
Missing enum 'VIR_ERR_NETWORK_PORT_EXIST'
Missing enum 'VIR_ERR_NO_NETWORK_PORT'
Missing enum 'VIR_NETWORK_PORT_CREATE_RECLAIM'
--- FAIL: TestAPICoverage (0.56s)
panic: Missing symbols found [recovered]
	panic: Missing symbols found

goroutine 5 [running]:
panic(0x56180a8aa1c0, 0xc4204484d0)
	/usr/lib/go-1.7/src/runtime/panic.go:500 +0x1a1
testing.tRunner.func1(0xc420078180)
	/usr/lib/go-1.7/src/testing/testing.go:579 +0x25d
panic(0x56180a8aa1c0, 0xc4204484d0)
	/usr/lib/go-1.7/src/runtime/panic.go:458 +0x243
_<https://ci.centos.org/job/libvirt-go-check/systems=libvirt-debian-9/ws/.TestAPICoverage(0xc420078180)>
	<https://ci.centos.org/job/libvirt-go-check/systems=libvirt-debian-9/ws/api_test.go>:501 +0x5ff
testing.tRunner(0xc420078180, 0x56180a8fd908)
	/usr/lib/go-1.7/src/testing/testing.go:610 +0x81
created by testing.(*T).Run
	/usr/lib/go-1.7/src/testing/testing.go:646 +0x2ec
exit status 2
FAIL	_<https://ci.centos.org/job/libvirt-go-check/systems=libvirt-debian-9/ws/>	0.663s
Build step 'Execute shell' marked build as failure


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]