[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Windows Client



Thank you for your swift response.  However, still not able to connect to the ubuntu libvirtd.  Have you ever seen a grown man cry?

Edited /etc/libvirt/libvirt.conf as follows:
listen_tcp = 1
auth_tcp = "none"

Edited /etc/default//libvirt-bin as follows:
libvirt-opts="-d -l"

Running virsh on Vista client fails as follows:
$ virsh -c qemu+tcp://192.168.1.101/system
error: unable to connect to libvirtd at '192.168.1.101': errno=10061
error: failed to connect to the hypervisor

Running virsh on Ubuntu server fails as follows:
$ virsh -c qemu+tcp:///system
Connecting to uri: qemu+tcp:///system
error: unable to connect to libvirtd at 'localhost': Connection refused
error: failed to connect to the hypervisor

Indeed, with libvirt-opts="-d -l" in etc/default//libvirt-bin the 'default' command also fails:
$ virsh -c qemu:///system
Connecting to uri: qemu:///system
error: unable to connect to 'var/run/libvirt/libvirt-sock': Connection refused
error: failed to connect to the hypervisor

The rationale for using insecure TCP was to quickly prove a concept with the minimum of fuss.  Perhaps this is not the way forward.  Suggestions very welcome...

Tim McLeod


-----Original Message-----
From: Matthias Bolte [mailto:matthias bolte googlemail com] 
Sent: 28 April 2010 15:36
To: tim mcleod simulamen eu
Cc: libvirt-users redhat com
Subject: Re: Windows Client

2010/4/28 Tim McLeod <tim mcleod simulamen eu>:
> Having newly compiled a Libvirt on a Windows Vista machine (many thanks to
> Matthias Bolte)

Nine :)

> I have attempted to connect to a remote Ubuntu machine using
> virsh.exe.  However, the connection fails as follows:
>
>
>
> $ virsh -c qemu+tcp:///system

You need to specify the server in this URI using a hostname or IP
address: qemu+tcp://ubuntu-server.com/system

> error: unable to connect to libvirtd at 'localhost': errno=10061
>
> error: failed to connect to the hypervisor
>
>
>
> 1.  I have modified /etc/libvirt/libvirt.conf to set listen_tcp=1.

You also need to change this

   #auth_tcp = "sasl"

to

   auth_tcp = "none"

to disable SASL authentication/encryption for TCP connections, because
your libvirt on Windows is compiled without SASL support. If you need
the libvirt connections to be encrypted you can switch from TCP to TLS
connections using: qemu+tls://ubuntu-server.com/system

> 2.  I cannot find /etc/sysconfig/libvirtd so I am unable to set
> LIBVIRTD_ARGS="--listen".
>

For Ubuntu packaged libvirt see /etc/default/libvirt-bin and change

   libvirtd_opts="-d"

to

   libvirtd_opts="-d -l"

as the comment suggest and restart libvirtd using

   /etc/init.d/libvirt-bin restart

Now you should be able to connect to the libvirtd on your Ubuntu server.

Matthias



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]