[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] libvirt unavailable while a VM is in migration?



Did a bit more testing. I open a connection to the hypervisor from
python using:
con = libvirt.open('qemu:///system')

No call that I tried on con returns while a migration is in progress. I
tried: listDomainsID, lookupByID, getInfo, getHostname, getType.

This sort of combines with my other outstanding email, about how to use
migrateSetMaxDowntime. If I can't even get a domain object for a
migrating domain, how could I possibly set max downtime AFTER the
migration has begun?

I must be missing something crucial. Can someone please give me some
wisdom?

--Igor

On Fri, Dec 17, 2010 at 02:06:27AM -0600, Igor Serebryany wrote:
> Hi, 
> 
> 	I am running libvirt 0.8.6 on qemu (kvm, really) 0.12.5. I have
> 	noticed that while a live migration is running, I cannot do anything
> 	else with libvirt -- even 'virsh list' blocks without output until
> 	the migration is almost done.
> 
> 	(At that point 'virsh list' will dump a final screen showing the VM I
> 	just migrated as 'running'; the next run of 'virsh list' no longer
> 	displays the VM -- this is why I say "almost done".)
> 
> 	Is there anything I can do to prevent this? Is there a fix for this
> 	coming?
> 
> 	MORE DETAILS:
> 
> 	I open a connection to a remote libvirt instance and begin a
> 	live-migration using:
> 	domain.migrate(remoteCon, flags, None, None, 0)
> 
> 	My flags are:
> 	flags = libvirt.VIR_MIGRATE_PEER2PEER | libvirt.VIR_MIGRATE_LIVE | libvirt.VIR_MIGRATE_UNDEFINE_SOURCE | libvirt.VIR_MIGRATE_TUNNELLED
> 
> Thanks,
> --Igor



> _______________________________________________
> libvirt-users mailing list
> libvirt-users redhat com
> https://www.redhat.com/mailman/listinfo/libvirt-users

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]