[libvirt-users] problem with dependencies

Daniel P. Berrange berrange at redhat.com
Mon Feb 15 11:12:52 UTC 2010

On Sun, Feb 14, 2010 at 06:41:39PM +0200, monitz wrote:
> hello
> i have been having trouble installing libvirt
> i installed kvm-kmod on rhel 5.4 kernel 2.6.18 without issues using an rpm
> from the redhat website
> after installation i tested it by creating an img file with qemu image and
> went ahead to install libvirt and libvirt-python for virtmanager
> however during installation of libvirt i get the following error:
> failed dependencies /usr/bin/qemu-img
> since qemu-img is in /usr/local/kvm/bin on my system i tried adding it to
> $PATH, symlinking the file and even copying the binery to /usr/bin but to no
> use
> compilation from source seemed to go fine but after that libvirt-python
> could still not find libvirt
> is there any solution to this issue? , i would imagine it is a known one

libvirt on RHEL5 expoects KVM to be in /usr/bin or /usr/libexec

|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|

More information about the libvirt-users mailing list