[libvirt-users] Listing machines as non-root user

Maciej Gałkiewicz maciej.galkiewicz at gmail.com
Wed Apr 27 07:28:36 UTC 2011

2011/4/26 Jan <jan at agetty.de>

> have you tried a different connection URI?:
> --------------<-----------------
> $ virsh -c qemu:///system 'list'
> -------------->-----------------
> If not explicitly stated, the virsh binary uses the 'qemu:///session' URI
> (at least under debian).
> See also .. VIRSH(1):
> ----------------------------------<---------------------------------------
> qemu:///system
> "connect locally as root to the daemon supervising QEmu and KVM domains"
> qemu:///session
> "connect locally as a normal user to his own set of QEmu and KVM domains"
> ---------------------------------->---------------------------------------
> Please note that in order for the 'qemu:///system' URI to work probably the
> user must be part of the 'libvirt' group. This way you won't have to touch
> the permission set of any of the respective sockets.

My user is in libvirt group
$ id
uid=107(eucalyptus) gid=112(eucalyptus) groups=112(eucalyptus),110(libvirt)

I have tried 'virsh -c qemu:///system 'list'' as well. Still does not work.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20110427/63133662/attachment.htm>

More information about the libvirt-users mailing list