[libvirt-users] Listing machines as non-root user

Jan jan at agetty.de
Tue Apr 26 13:14:03 UTC 2011

Hi Maciej,

On 04/26/2011 09:13 AM Maciej Gałkiewicz wrote:
> I have a problem with virsh. I'm using eucalyptus software on top of xen 4
> (debian squeeze). The problem is that unix user "eucalyptus" cannot see vm
> machines when it executes "virsh list". My libvirt version is 0.8.8-3 from
> debian sid repository. The same
> problem occurs with older versions.
> What is more I have tried to change unix_sock_ro_perms  to "2777". After
> libvirt restart it started to work. Even when I reverted this change it was
> still working. Unfortunately after server restart virsh still does not work
> (I am not sure but I cannot restart my production servers right now).
> Everything is fine when I run virsh as root. I have the same issue on 7
> machines.

have you tried a different connection URI?:

$ virsh -c qemu:///system 'list'

If not explicitly stated, the virsh binary uses the 'qemu:///session' URI
(at least under debian).

See also .. VIRSH(1):

"connect locally as root to the daemon supervising QEmu and KVM domains"

"connect locally as a normal user to his own set of QEmu and KVM domains"

Please note that in order for the 'qemu:///system' URI to work probably the
user must be part of the 'libvirt' group. This way you won't have to touch
the permission set of any of the respective sockets.

I hope this helps ;)


More information about the libvirt-users mailing list