[libvirt-users] ERROR Unable to deny all devices for (solution)

Lucas Arbiza lucas.arbiza at gmail.com
Thu Jan 13 17:54:59 UTC 2011

Hi. This is not a question, I had the following problem and I want to share
my solution.


I tried to create a new virtual machine with this command:

$ virt-install --connect qemu:///system -n vmTeste -r 512 -f
/var/lib/libvirt/images/vmTeste.qcow2 -s 2 -c
/media/Data/isos/debian-506-amd64-netinst.iso --vnc --noautoconsole
--accelerate --hvm

And I got this error:

ERROR    Unable to deny all devices for vmTeste: No such file or directory
Traceback (most recent call last):
  File "/usr/bin/virt-install", line 1033, in <module>
  File "/usr/bin/virt-install", line 915, in main
    start_time, guest.start_install)
  File "/usr/bin/virt-install", line 957, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/lib/pymodules/python2.6/virtinst/Guest.py", line 973, in
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/pymodules/python2.6/virtinst/Guest.py", line 1038, in
  File "/usr/lib/pymodules/python2.6/virtinst/Guest.py", line 1009, in
    dom = self.conn.createLinux(start_xml, 0)
  File "/usr/lib/python2.6/dist-packages/libvirt.py", line 1277, in
    if ret is None:raise libvirtError('virDomainCreateLinux() failed',
libvirtError: Unable to deny all devices for vmTeste: No such file or

I found the same error looking for in the internet, similar errors including
in this list. I tried to solve changing permissions, editing xml and
defining the virtual machine, etc.

No long time ago I made some changes to optimize kernel performance for
desktop as described here (it's in Portuguese, but can be undertood reading
the commands and files) and this changes caused the above errors (in Ubuntu
10.10 and Fedora 14).  I undid the changes and I had no more errors.

Possibly I can be wrong, but it worked for me.

*Lucas Arbiza*

email: lucas.arbiza at gmail.com
celular: +55 (55) 9152 7561

Twitter: http://twitter.com/lucasarbiza
Facebook: http://www.facebook.com/lucas.arbiza
Google Profile: http://www.google.com/profiles/lucas.arbiza
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20110113/42bb49e5/attachment.htm>

More information about the libvirt-users mailing list