[libvirt-users] invalid argument error when using cache parameter

Daniel P. Berrange berrange at redhat.com
Mon Jan 24 11:26:36 UTC 2011

On Sat, Jan 22, 2011 at 12:49:55AM -0600, Igor Serebryany wrote:
> hi, 
> 	i tried to add a 'cache' argument to the 'driver' element in my
> 	domainxml for qemu/kvm. i tried adding cache="none" as well as
> 	"writethrough" and "writeback", but every time i get these errors:
> libvirtError: internal error process exited while connecting to monitor: char device redirected to /dev/pts/1
> qemu: could not open disk image /vms/test.img: Invalid argument 
> 	the full driver line looks like this:
> 	<driver name="qemu" type="raw" cache="none"/>
> 	the same domainxml works just fine without the cache parameter. does
> 	anyone know what i'm doing wrong? is there some other way to set the
> 	default cache policy on qemu/kvm? i didn't see anything in the
> 	config file...

What filesystem type is /vms ?  I've seen this error message when
the filesystem did not support O_DIRECT, which cache=none enables


More information about the libvirt-users mailing list