[libvirt-users] Resizing ext4 fedora qemu guest

Alex mysqlstudent at gmail.com
Wed Jun 8 01:27:38 UTC 2011


I have a fedora14 host with a fedora15 guest and I'm trying to resize
the /home partition from 200GB to 240GB. I'm relatively new to the
virsh/guestfish commands, as well as LVM, although I think I have a
reasonable understanding. I have followed the virt-resize directions
(http://libguestfs.org/virt-resize.1.html), but it still shows 200GB:

# fdisk -l /dev/mapper/vg_custserv-lv_home

Disk /dev/mapper/vg_custserv-lv_home: 197.2 GB, 197165842432 bytes
255 heads, 63 sectors/track, 23970 cylinders, total 385089536 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Outside of the guest, I see this:

# virt-filesystems --long --parts --lvs -h -a newdisk.img
Name                      Type       Size  Parent
/dev/vg_custserv/lv_home  lv         184G  /dev/vg_custserv
/dev/vg_custserv/lv_root  lv         50G   /dev/vg_custserv
/dev/vg_custserv/lv_swap  lv         5.9G  /dev/vg_custserv
/dev/sda1                 partition  500M  /dev/sda
/dev/sda2                 partition  240G  /dev/sda

The partition is the correct size, but it appears the volume group(?)
is not the correct size. fdisk from within the guest also shows the
correct size for the device. I've tried resize2fs from within the
guest. Does virt-resize understand the ext4 filesystem and how to
properly resize it? Is that my problem?

I've also tried using guestfish with lvresize-free without success:

<fs> lvresize-free /dev/mapper/vg_custserv-lv_home 100
libguestfs: error: lvresize_free:   New size (5876 extents) matches
existing size (5876 extents)
  Run `lvresize --help' for more information.

I'm really not sure what to do next. Any ideas greatly appreciated.


More information about the libvirt-users mailing list