[libvirt-users] Problems migrating xen domains

Lorenzo Milesi maxxer at ufficyo.com
Sat Jun 18 09:29:17 UTC 2011


I've set up a cluster with two Debian 6 nodes, running Xen 4 and libvirt 0.9 (from backports).
My VMs run over a DRBD resource, to allow live migration between the nodes. 

I've successfully tried live migration using xm migrate, now I'd like to make it work using virsh, but cannot make it. Here's the error I'm getting:

# virsh migrate  efw xen+ssh://
error: POST operation failed: xend_post: error from xen daemon: (xend.err "can't connect: (-2, 'Name or service not known')")

As said, xm migrate worked at first, so xend should be set up correctly.
I've done several searches but with no luck.

What could be the problem?

Relevant configs:

# cat /etc/xen/xend-config.sxp |grep -v ^#|grep -v ^$
(xend-http-server yes)
(xend-unix-server yes)
(xend-relocation-server yes)
(xend-port            8000)
(xend-relocation-port 8002)
(vif-script vif-bridge)
(dom0-min-mem 196)
(enable-dom0-ballooning yes)
(total_available_memory 0) 
(dom0-cpus 0)
(vncpasswd '')


root at xensrv01:~# virsh version
Compiled against library: libvir 0.9.0
Using library: libvir 0.9.0
Using API: Xen 3.0.1
Running hypervisor: Xen 4.0.0

More information about the libvirt-users mailing list