[libvirt-users] Booting from scsi [SOLVED]

bhasker at unixindia.com bhasker at unixindia.com
Fri May 13 15:47:46 UTC 2011

Changing the domain type from qemu to kvm fixes this

On Fri, 13 May 2011, bhasker at unixindia.com wrote:

> Hi all,
> I am starting up to use libvirt with virsh and virt-install. I used
> virt-install successfully and have a running linux system with raw disk 
> exported to the virtual machine as scsi. (the whole of qemu + libvirt + 
> virtmanager is compiled and installed on /usr/local from source)
> After the virtual OS installation (which succeeds) I am not able to boot 
> into the OS from the harddisk. Following are some excerpts from my xml file. 
> Please get back to me if you need any more information
>  <os>
>    <type arch='x86_64' machine='pc-0.14'>hvm</type>
>    <boot dev='hd'/>
>    <bootmenu enable='yes'/>
>  </os>
> I also tried removing the boot parametes from <os> and added
> <boot order='1'/> in the scsi disk section. Still I am not able to use the 
> scsi disk to boot (my qemu-system-x86_64 however has the boot=on option)
>    <disk type='block' device='disk'>
>      <driver name='qemu' type='raw'/>
>      <source dev='/dev/venkatb1/deb'/>
>      <target dev='sda' bus='scsi'/>
>      <address type='drive' controller='0' bus='0' unit='0'/>
>    </disk>
> I could not find any more information or any posts where someone else had 
> faced this issue. I presume I am doing something wrong here.
> Can someone help please ?
> thanks
> Bhasker C V
> _______________________________________________
> libvirt-users mailing list
> libvirt-users at redhat.com
> https://www.redhat.com/mailman/listinfo/libvirt-users

More information about the libvirt-users mailing list