[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] libvirt, OSX and VirtualBox - how?



On Sun, Nov 06, 2011 at 10:24:01AM +0100, Matthias Bolte wrote:
> > * Installed VirtualBox
> 
> Which version?

v4.1.4 r74291 (the current version when I downloaded it 2 days ago)

> vbox:///session is the correct URI.

OK, that's good to know.

> I don't have an OSX at hand for testing, but you can try
> 
> LIBVIRT_LOG_FILTERS=1:vbox virsh -c vbox:///session
> 
> and post the output here. This might give a hint about what's wrong.

Brians-MacBook-Air:~ $ LIBVIRT_LOG_FILTERS=1:vbox virsh -c vbox:///session
18:11:05.910: -1: info : libvirt version: 0.9.6
18:11:05.910: -1: debug : tryLoadOne:163 : Found VBoxXPCOMC.dylib in '/Applications/VirtualBox.app/Contents/MacOS'
18:11:05.910: -1: debug : vboxRegister:94 : VBoxCGlueInit found API version: 4.1.4 (4001004)
18:11:05.910: -1: debug : vboxRegister:126 : Unsupport VirtualBox API version
error: internal error unable to initialize VirtualBox driver API
error: failed to connect to the hypervisor

Looks like libvirt doesn't grok this version of VirtualBox. The version of
libvirt which Homebrew built was:

  homepage 'http://www.libvirt.org'
  url 'ftp://libvirt.org/libvirt/libvirt-0.9.6.tar.gz'
  sha256 'ce29b1cd3067b224aa834fec2a93d7613c0e72bc035760ad536a2142430bc02b'

This seems to be latest stable version - should I try 0.9.7rc2?

Aha: 7 days ago...
http://libvirt.org/git/?p=libvirt.git;a=commit;h=73ce5050e0dcf897a975fd077d249f42e0549c64

Regards,

Brian.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]