[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] diificulty installing or building libvert



I am unable to install or build libvert for RHEL4-64. Due to the errors below. Is it because all the source/rpms are for Fedora? I don't see any redhat versions on the sources page. Thanks in advance for any help.


When running make against the untarred /libvirt-0.9.4.tar.gz configure succeeds but make fails.

make  all-am

make[3]: Entering directory `/home/jgaer/Desktop/NiFi/libvirt-0.9.4/src'
  CC     libvirt_driver_nwfilter_la-nwfilter_learnipaddr.lo
nwfilter/nwfilter_learnipaddr.c: In function 'learnIPAddressThread':
nwfilter/nwfilter_learnipaddr.c:522: error: 'ETHERTYPE_VLAN' undeclared (first use in this function)
nwfilter/nwfilter_learnipaddr.c:522: error: (Each undeclared identifier is reported only once
nwfilter/nwfilter_learnipaddr.c:522: error: for each function it appears in.)


installing the src rpm fails

jgaer ljgaer_~/Desktop/NiFi: sudo rpm -i libvirt-0.9.0-1.fc14.src.rpm

[sudo] password for jgaer:
warning: libvirt-0.9.0-1.fc14.src.rpm: Header V3 DSA signature: NOKEY, key ID de95bc1f
warning: user veillard does not exist - using root
warning: group www does not exist - using root
error: unpacking of archive failed on file /usr/src/redhat/SOURCES/libvirt-0.9.0.tar.gz;4ebd4829: cpio: MD5 sum mismatch


when trying to install  rpm -i  libvirt-0.9.7-1.fc14.x86_64.rpm
 even with –force I get a long list of unresolved dependencies including all previous versions of libvirt.so

Trying to use rpmbuild results in the following missing dependancies. I am unable to build or install the libpcap-devel because of a dependency on libcap1 which seems to only exist for suse,


jgaer ljgaer_~/Desktop/NiFi: sudo rpmbuild -ta libvirt-0.9.4.tar.gz

[sudo] password for jgaer:

error: Failed build dependencies:

        libtasn1-devel is needed by libvirt-0.9.4-1.x86_64
        libpcap-devel is needed by libvirt-0.9.4-1.x86_64
        libnl-devel is needed by libvirt-0.9.4-1.x86_64
        radvd is needed by libvirt-0.9.4-1.x86_64
        ebtables is needed by libvirt-0.9.4-1.x86_64
        /usr/bin/qemu-img is needed by libvirt-0.9.4-1.x86_64
        parted-devel is needed by libvirt-0.9.4-1.x86_64
        device-mapper-devel is needed by libvirt-0.9.4-1.x86_64
        numactl-devel is needed by libvirt-0.9.4-1.x86_64
        libssh2-devel is needed by libvirt-0.9.4-1.x86_64

Jeff




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]