[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] diificulty installing or building libvert



On 11/11/2011 09:29 AM, Jeff Gaer wrote:
> I am unable to install or build libvert for RHEL4-64. Due to the errors below. Is it because all the source/rpms are for Fedora? I don't see any redhat versions on the sources page. Thanks in advance for any help.

libvirt is not supported as an rpm for RHEL 4 (it is maintained for RHEL
5, although these days most development appears to be focused on RHEL 6).

> When running make against the untarred /libvirt-0.9.4.tar.gz configure succeeds but make fails.
> 
> make  all-am
> 
> make[3]: Entering directory `/home/jgaer/Desktop/NiFi/libvirt-0.9.4/src'
>   CC     libvirt_driver_nwfilter_la-nwfilter_learnipaddr.lo
> nwfilter/nwfilter_learnipaddr.c: In function 'learnIPAddressThread':
> nwfilter/nwfilter_learnipaddr.c:522: error: 'ETHERTYPE_VLAN' undeclared (first use in this function)
> nwfilter/nwfilter_learnipaddr.c:522: error: (Each undeclared identifier is reported only once
> nwfilter/nwfilter_learnipaddr.c:522: error: for each function it appears in.)

That means that you'll have to do some back-porting work yourself, since
no one else on this list has tried to build for something as old as RHEL
4.  Sorry I couldn't be of more help.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]