[libvirt-users] hooks not working on Ubuntu

Zoltan Lippai zoli at lippai.net
Sun Jan 8 23:06:03 UTC 2012

In the meantime I was able to install 0.9.7 version of libvirt, but everything remained the same unfortunately.

On 2012.01.08., at 23:52, Zoltan Lippai wrote:

> Hi everybody!
> I was trying to set up port forwarding to one of my VM's but I'm stuck.
> I was following this guide:
> http://wiki.libvirt.org/page/Networking#Forwarding_Incoming_Connections
> So I've created the hook script but it seems like libvirt is not calling it upon the start of the VM.
> I've put this into the hook script:
> date >> /tmp/libvirt-hook-debug
> but the file was never created.
> Also I put this in the script:
> echo "Could not find required XYZZY" >&2
> exit 1
> (just to make sure)
> This should show up in the libvirt log, but it's not there. 
> I think it is safe to say, that this script is never called.
> I am using Ubuntu 11.10 and I know about the apparmor.d bug (https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/891472) so I tried to change the apparmor profile as suggested, I even tried to turn apparmor off temporarily (service apparmor teardown) but still no luck.
> I have libvirt 0.9.2-4ubuntu15.1 (they say the bug is fixed in 0.9.7 but it's not yet available in the repo and I'm not even sure, that my problem is related to that bug).
> So do you have any idea what could be going on in here?
> Thanks,
> Zoltan Lippai

More information about the libvirt-users mailing list