[libvirt-users] libvirt 0.9.9: could not open /dev/net/tun: Operation not permitted

Fischer, Anna anna.fischer at hp.com
Mon Jan 23 09:25:49 UTC 2012

Hi, I'm running the latest libvirt 0.9.9.

I'm trying to start a VIF of type "Ethernet". I know there are problems with that because you need to be root in order to control the tun/tap driver.

I changed my qemu.conf file to

user = "root"
group = "root"
clear_emulator_capabilities = 0

However, I still get an error when trying to start my VM:

[root]# virsh start vm-0-3
error: Failed to start domain vm-0-3
error: internal error process exited while connecting to monitor: qemu-system-x86_64: -net tap,ifname=vif-0-3,script=/etc/libvirt/qemu/vif-vnet-up,vlan=0,name=hostnet0: could not open /dev/net/tun: Operation not permitted
qemu-system-x86_64: -net tap,ifname=vif-0-3,script=/etc/libvirt/qemu/vif-vnet-up,vlan=0,name=hostnet0: Device 'tap' could not be initialized

I run the latest qemu-kvm.

The permissions on the tun device are set to default settings and my scripts are executable by anyone:

[root ~]# ll /dev/net/tun 
crw-rw---- 1 root root 10, 200 Jan 20 15:39 /dev/net/tun

[root ~]# ll /etc/libvirt/qemu/vif-vnet-*
-rwxrwxrwx 1 root root 150 Jan 17 15:52 /etc/libvirt/qemu/vif-vnet-down
-rwxrwxrwx 1 root root 137 Jan 19 17:51 /etc/libvirt/qemu/vif-vnet-up

Any idea what I'm doing wrong here? I have actually also compiled libvirt with --without capng, so it should not drop capabilities anyway. Why does it not run as root?


More information about the libvirt-users mailing list