[libvirt-users] oVirt setup issues

Christian Parpart trapni at gmail.com
Mon Jan 23 11:02:05 UTC 2012

Hi all,

as suggested in a prior mail, I was now trying out oVirt - however, on
a non-Redhat/Debian system -
and ran into huge issues primary due to the lag of information / documenation.

So here my assumptions:
* oVirt is a web application based on JBoss application server.
* VDSM is an agent to run on every hypervisor (or also VM?)
* nothing else needed? (despite jboss, java-jdk-1.6, python-2.7, maven-2.2)

I tried following the install-from-source guides for oVirt and failed at
a compilation error.

# make
[INFO] Compiling 186 source files to
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Compilation failure
error: PGHack is not abstract and does not override abstract method
getParentLogger() in CommonDataSource

There are no remote branches nor tags that looked like "stable" that I
could test on, too.

So finally (the not favoured version), I tried putting a Fedora 16
netinstall into a KVM on my hypervisor-test-node
and installed everything in there, again, following some guide from
the upstream site.

Since it did not compile anything, the install worked well, but I
could not add my hypervisor node
as a host, in fact, it complained about some tools not being able to
be installed.

What tools? VDSM? how am I supposed to "cleanly" install it if not as
promoted on the install guide? :(

In the end, I am having nothing working, feeling a little bit sad
about the possibly wasted time,
so I hope you guys can give me a hint on how to deal with VDSM (if
that's what I am missing here)
and how to deal with the compile error when installing from source.

Best regards,
Christian Parpart.

More information about the libvirt-users mailing list