[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] virsh iface-list () - function is not supported



Hi
Thanks for the response. I installed using apt-get on ubuntu 12 04, should i be compiling libvirt myself with --with-netcf option instead of using any package manager?

Regards
Ananth

On 02-Jul-2012 3:00 PM, "Osier Yang" <jyang redhat com> wrote:
On 2012年07月02日 17:24, Ananth wrote:
Hi,
I am using KVM hypervisor on Ubuntu 12.04 (libvirt-0.9.8). The call to
list the interfaces seem to be failing on this version of libvirt as
seen below.

virsh # iface-list
error: Failed to list active interfaces
error: this function is not supported by the connection driver:
virConnectNumOfInterfaces

Sounds like your build is built without --with-netcf.


I have seen this issue with libvirt 0.9.2 as well, which seemed to be
working in 0.9.4 version.

Is there any work around for this or any alternate way of querying the
interfaces and bridges through libvirt?

No other way currently, as implementation based on netcf is the only
backend of interface driver now.

Regards,
Osier

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]