[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] About libvirtd daemon start issue



Hi libvirt team,

I found there are very few documents to mention how to launch a libvirtd daemon when built from the source code. A moment ago, I un-install all the kvm related stuff (kvm module, libvirt, virt-manager, virsh, qemu-kvm...) from my ubuntu system.
Then I built the libvirt from the source tar package:

1. #./autogen.sh --system --with-phyp --enable-debug=yes CFLAGS=-g
2. #make
3. #make install

Everything is OK :), but wait a minute --

According to the instruction in libvirt.org, the option flag "--system" in above step 1 will make the environment is the same as the pre-built package installation, eg, apt-get install ... because I found that the "libvirtd" daemon is not active with "ps aux | grep libvirtd", so I try to start it manually:

Method 1: root dennis-:/home/dennis/workspace/AIX# service libvirtd start
libvirtd: unrecognized service

Method 2: root dennis-:/home/dennis/workspace/AIX# /etc/init.d/libvirtd start
bash: /etc/init.d/libvirtd: No such file or directory

Method 3: root dennis-:/home/dennis/workspace/AIX# /usr/sbin/libvirtd start
2012-07-05 09:20:42.225+0000: 32749: info : libvirt version: 0.9.12
2012-07-05 09:20:42.225+0000: 32749: error : virDomainDefParseXML:8303 : unknown OS type hvm

I don't know if the method 3 is success or not, but I have no time to verify it now, because I have to leave the office now for the later traffic jam... Why "unknow OS type hvm"?

If my experiment is useful, then please document it in the libvirt.org page...

BRs,
Dennis


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]