[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] VM dies with error regarding "virConnectNumOfInterfaces"



Hi!

I ran into a problem using a USB device and was wondering if
you could help me.

I'm running a Win XP SP3 in a VM with libvirt on a Xubuntu 11.10.
I configured it to talk to several USB devices.

With one particular device (a Phonak Compilot[1], admittedly a probably
rather unusual device), the VM dies with the following error in the
libvirtd.log:

2012-07-20 21:04:19.591+0000: 1282: error :
virConnectNumOfInterfaces:9803 : this function is not supported by the
connection driver: virConnectNumOfInterfaces
2012-07-20 21:05:05.762+0000: 1276: error : qemuMonitorIO:603 : internal
error End of file from monitor

This happens no matter if is it the only configured USB device or if
there is another USB device present in the config or not.

I configured it doing the following steps:

- I looked up the vendor / product ID using lsub

  Bus 001 Device 003: ID 180f:1002

(Interestingly, it does not show a name of the device here.)

- I added it to the VM's xml configuration using virsh / edit $vmname

<domain>
  ...
  <devices>
    ...
    <hostdev mode='subsystem' type='usb' managed='no'>
      <source>
        <vendor id='0x180f'/>
        <product id='0x1002'/>
      </source>
    </hostdev>
    ...
  </devices>
</domain>

- I run the VM using the virt-manager UI.

Any ideas what the problem could be? Do I need to run/configure
differently than how I did it? To me it sounds as if there is some
implementation missing? Is there a workaround for it?

I hope you can give me some clues.

Thank you!

Helga


[1]
http://www.phonak.com/com/b2c/en/products/accessories/compilot-tvlink-s/overview.html


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]