[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] INTERNAL ERROR:can not attach network interface for vm



hello,i got a error message when use virsh attach-interface for a vm:

first, list the vm's interface,there's no interface now.
virsh # domiflist ubuntum-124
Interface  Type       Source     Model       MAC
-------------------------------------------------------

then,i did an attach-interface action:
virsh # attach-interface ubuntum-124  bridge br0 --persistent
Interface attached successfully

virsh # domiflist ubuntum-124
Interface  Type       Source     Model       MAC
-------------------------------------------------------
vnet0      bridge     br0        -           52:54:00:3d:d1:ea

second,detach the interface:
virsh # detach-interface ubuntum-124 bridge
Interface detached successfully

virsh # domiflist ubuntum-124
Interface  Type       Source     Model       MAC
-------------------------------------------------------

3rd,attach interface again,at this step ,i got erros like below:
virsh # attach-interface ubuntum-124  bridge br0 --persistent
error: Failed to attach interface
error: internal error unable to execute QEMU command 'device_add':
Duplicate ID 'net0' for device

virsh # attach-interface ubuntum-124  bridge br0
error: Failed to attach interface
error: internal error unable to execute QEMU command 'device_add':
Duplicate ID 'net0' for device

virsh # version
Compiled against library: libvir 0.9.10
Using library: libvir 0.9.10
Using API: QEMU 0.9.10
Running hypervisor: QEMU 0.12.1

any one can help?thanks.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]