[libvirt-users] Problem using virt-manager to create a VM remotely

Dale Amon amon at vnl.com
Tue Mar 27 20:08:05 UTC 2012

Well, not that remote. I'm trying to get it working 
from my laptop to an ancient workstation behind me
I use for testing.

I appear to get the connection okay.

 virt-manager --connect qemu+ssh://root@<host_ip>/system

I can click on the entry on the panel that comes up and
see facts about the remote machine.

I then tried the "Create a new virtual machine" item on the
tool bar. Fine so far. I get a nice looking panel for New VM and
since this is just an experiment, I call it "test". The
correct Connection is showing, ie the host ip (QEMU). 

I accept the default "Local install media (ISO or CDROM)"
and go to the next panel. I take the "Use ISO Image" and
then give it the full directory path and name of the iso
on the remote machine <host_ip>. I have tried leaving 
OS Type and version Generic; I have also tried setting them
to match the iso (an 11.10 i386 server). When I attempt to
go forward, it gives me an error panel, "Error Setting install
media location. Checking installer location failed:
Could not find media '/KdevArchive1/ubuntu-11.10-server-i386.iso'

On the off chance that it was trying to mount the iso from
my laptop instead of the test machine, I have also tried pointing
to the path of the same iso there as well with no joy.

I am finding very little documentation on the GUI mode and
none of it seems to give me any indication of what is going


More information about the libvirt-users mailing list