[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] Libvirt Error guest wont start



Hi all,

I have been using Libvirt for several months now and I have only had minimal problems. I had a particular setup and was starting up multiple guests just fine. However, with seemingly no changes I now get the following error when trying to start a guest:

virsh start guest0
error: Failed to start domain guest0
error: internal error Process exited while reading console log output: Supported machines are:
pc         Standard PC (alias of pc-0.12)
pc-0.12    Standard PC (default)
pc-0.11    Standard PC, qemu 0.11
pc-0.10    Standard PC, qemu 0.10
isapc      ISA-only PC

Apparently, the machine argument settings were changed in recent versions of Libvirt. Or at least that is what it seems. My guest's OS settings were:

<os>
    <type arch='x86_64' machine='pc-1.1'>hvm</type>
    <boot dev='hd'/>
</os>


After getting this error I tried setting the machine argument to one of the "supported" ones. Then I get this error:

virsh start guest0
error: Failed to start domain guest0
error: Unable to read from monitor: Connection reset by peer

Anyone have any ideas as to why this happened all of a sudden? I was not having any problems before.

Thanks,
Shawn

--
Virginia Tech
Bradley Department of Electrical and Computer Engineering
B.S. Electrical Engineering
B.S. Computer Engineering


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]