[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] start and stop a VMware VM using libvirt API



Thanks for shedding some light Matthias. Seems like we both replied one minute apart.

On 10/23/2012 07:06 PM, Matthias Bolte wrote:
Okay, now I see the problem, old libvirt hat an ESX version check that
was to restrictive. There is no fundamental problem here.

It seems that you used the precompiled installer from here
http://libvirt.org/windows.html

Unfortunately that one is quite old, and should be updated. Current
libvirt version is 0.10.2, this one definitely works with ESXi 5.0.

There is a set of scripts that is used to build the content of the installer

https://github.com/photron/msys_setup

You can follow the instructions that come with the scripts to build libvirt.

You could also wait until I had time to update the installer. I think
I'll be able to provide a new version in the next days.



2012/10/23 Ali Nikzad <nikzad a gmail com>:
I used libvirt-0.8.8.
I think it is the last version on the website.


On Tue, Oct 23, 2012 at 9:44 AM, Abbas <akhan phi9 com> wrote:
Is your libvirt up-to-date?



On 10/23/2012 06:39 PM, Ali Nikzad wrote:
No, I just tried it but  it didn't connect.
After it gets the username and password it shows the following error
message:
error: internal error Expecting VI API major/minor version '2.5' or '4.x'
but found '5.0'

On Tue, Oct 23, 2012 at 6:42 AM, Matthias Bolte <
matthias bolte googlemail com> wrote:

The documentation is outdated. libvirt also supports ESXi 5.0.

What is the exact error you get?

You already said that it reports being connected to ESXi 5.0. Why do
you expect it to report 4.x?


2012/10/23 Abbas <akhan phi9 com>:
Yes, that seems to be correct.

The libvirt VMware ESX driver can manage VMware ESX/ESXi 3.5/4.x and
VMware GSX 2.0, also called VMware Server 2.0, and possibly later
versions.
Since 0.8.3 the driver can also connect to a VMware vCenter 2.5/4.x
(VPX).



On 10/23/2012 07:40 AM, Ali Nikzad wrote:
Thank you Abbas,
I already tried it but I got a message saying it found version 5.0
instead
of 4.x. It seems that libvirt does not support ESXi 5.0.
I used the command in libvirt-0.8.8 the windows version.

Ali


On Mon, Oct 22, 2012 at 10:05 PM, Abbas <akhan phi9 com> wrote:

    You could write a bash or batch script to do that.
Normal connect format is "virsh -c esx://yournode"

"virsh start [domain]" is what starts a VM. Refer to the man pages
for
virsh command set.


/Abbas



On 10/23/2012 02:47 AM, Ali Nikzad wrote:

Hi,

I am a new libvirt user and I wonder if I can use this library to
start
or
stop a VM in ESXi 5.0.
For example to write an application using libvirt in windows or linux
that
connects to an ESXi 5.0 server and get the list of VMs and start one
of
them.

If so, is there any sample about it?

Thank you,
Ali




_______________________________________________
libvirt-users mailing
listlibvirt-users redhat comhttps://
www.redhat.com/mailman/listinfo/libvirt-users



_______________________________________________
libvirt-users mailing list
libvirt-users redhat com
https://www.redhat.com/mailman/listinfo/libvirt-users

_______________________________________________
libvirt-users mailing list
libvirt-users redhat com
https://www.redhat.com/mailman/listinfo/libvirt-users


--
Matthias Bolte
http://photron.blogspot.com







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]