[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] (Xen + libvirt) Installing and workin with xen -4.2.1 and libvirt 1.1.2



hi,

i found something im my log: (libvirtd.log)

i dont know about this. but it may be helpful for you. So i am forwarding this.

2013-09-26 11:43:58.507+0000: 10718: error : virDriverLoadModule:78 : failed to load module /usr/local/lib/libvirt/connection-driver/libvirt_driver_libxl.so /usr/lib/libxenlight.so.2.0: undefined symbol: xs_check_watch
2013-09-26 11:43:58.790+0000: 10729: error : virCommandWait:2348 : internal error: Child process (LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin HOME=/root USER=root LOGNAME=root /usr/bin/kvm -no-user-config -device '?' -device 'pci-assign,?' -device 'virtio-blk-pci,?' -device 'virtio-net-pci,?' -device 'scsi-disk,?' -device 'PIIX4_PM,?' -device 'usb-redir,?' -device 'ide-drive,?' -device 'usb-host,?' -device 'scsi-generic,?') unexpected exit status 1: Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
No accelerator found!

2013-09-26 11:43:58.838+0000: 10729: error : virCommandWait:2348 : internal error: Child process (LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin HOME=/root USER=root LOGNAME=root /usr/bin/kvm -no-user-config -device '?' -device 'pci-assign,?' -device 'virtio-blk-pci,?' -device 'virtio-net-pci,?' -device 'scsi-disk,?' -device 'PIIX4_PM,?' -device 'usb-redir,?' -device 'ide-drive,?' -device 'usb-host,?' -device 'scsi-generic,?') unexpected exit status 1: Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
No accelerator found!

2013-09-26 12:20:14.030+0000: 10721: error : xenHypervisorDoV2Sys:1011 : Unable to issue hypervisor ioctl 3166208: Permission denied
2013-09-26 12:20:14.030+0000: 10721: error : xenHypervisorDoV2Sys:1011 : Unable to issue hypervisor ioctl 3166208: Permission denied
2013-09-26 12:20:14.030+0000: 10721: error : xenHypervisorDoV2Sys:1011 : Unable to issue hypervisor ioctl 3166208: Permission denied
2013-09-26 12:20:14.030+0000: 10721: error : xenHypervisorDoV2Sys:1011 : Unable to issue hypervisor ioctl 3166208: Permission denied
2013-09-26 12:20:14.030+0000: 10721: error : xenHypervisorDoV2Sys:1011 : Unable to issue hypervisor ioctl 3166208: Permission denied
2013-09-26 12:20:14.030+0000: 10721: error : xenHypervisorDoV2Sys:1011 : Unable to issue hypervisor ioctl 3166208: Permission denied

*********
suggest me some solutions.

Regards,
cooldharma06
                                                                                                                                           


On Mon, Sep 30, 2013 at 6:36 PM, cooldharma06 <cooldharma06 gmail com> wrote:
hi,

i am using debian flavor called BOSS.

uname -a
Linux boss 3.2.0-4-amd64 #1 SMP Debian 3.2.41-2 x86_64 GNU/Linux

i installed XEN-4.2.1 from the source.

virsh # version
error: failed to connect to the hypervisor
error: no valid connection
error: Failed to connect socket to '/usr/local/var/run/libvirt/libvirt-sock': No such file or directory

root boss[src]#libvirtd -v
2013-09-30 13:05:36.836+0000: 8199: info : libvirt version: 1.1.2
2013-09-30 13:05:36.836+0000: 8199: error : libxlCapsInitHost:86 : internal error: Failed to get node physical info from libxenlight
2013-09-30 13:05:36.836+0000: 8199: error : libxlStateInitialize:1362 : cannot create capabilities for libxenlight
2013-09-30 13:05:36.836+0000: 8199: error : virStateInitialize:840 : Initialization of LIBXL state driver failed: internal error: Failed to get node physical info from libxenlight
2013-09-30 13:05:36.836+0000: 8199: error : daemonRunStateInit:909 : Driver state initialization failed


root boss[src]#libvirtd --version
/opt/libvirt-1.1.2/daemon/.libs/lt-libvirtd (libvirt) 1.1.2

these are the things which is in my system.

Regards,
cooldharma06.



On Mon, Sep 30, 2013 at 4:23 PM, Dario Faggioli <dario faggioli citrix com> wrote:
On lun, 2013-09-30 at 11:27 +0530, cooldharma06 wrote:
> hi,
>
Hi,

> thanks for your response.
>
>
> i cleaned that above one and installed in this following steps:
>
>
> * sudo apt-get install gcc make pkg-config libxml2-dev libgnutils-dev
> libdevmapper-dev libcurl4-gnutls-dev python-dev libpciaccess-dev
> libxen-dev libnl-dev
>
Oh, so you are on Debian/Ubuntu... Which version (so that I can try to
replicate your configuration) ?

> * ./configure = --prefix=/usr --localstatedir=/var --sysconfdir=/etc
> --with-xen=yes --with-libxl=yes
>
Mmm... ok, that's the libvirt part. How did you install Xen? I'm sure I
asked that already, but I can't remember whether or no you answered (if
yes, sorry).

Last time I tired to compile libvirt with libxl=yes on a Debian system
it was failing because of some issues with the Xen Debian packages (or
so I recall), although that was with Xen 4.3.0.

So, did you also build Xen yourself or you apt-get installed it?

> root boss[daemon]#xl info -n
> host                   : boss
> release                : 3.2.0-4-amd64
> version                : #1 SMP Debian 3.2.41-2
> machine                : x86_64
> nr_cpus                : 8
> max_cpu_id             : 7
> nr_nodes               : 1
> cores_per_socket       : 4
> threads_per_core       : 2
> cpu_mhz                : 3392
> hw_caps                :
> bfebfbff:28100800:00000000:00007f40:77bae3ff:00000000:00000001:00000281
> virt_caps              : hvm
> total_memory           : 3970
> free_memory            : 442
> sharing_freed_memory   : 0
> sharing_used_memory    : 0
> free_cpus              : 0
> cpu_topology           :
> cpu:    core    socket     node
>   0:       0        0        0
>   1:       0        0        0
>   2:       1        0        0
>   3:       1        0        0
>   4:       2        0        0
>   5:       2        0        0
>   6:       3        0        0
>   7:       3        0        0
> numa_info              :
> node:    memsize    memfree    distances
>    0:      4590        442      10
> xen_major              : 4
> xen_minor              : 2
> xen_extra              : .1
>
Mmm... I have to admit that the most of the testing I did when working
on the patch for libvirt that introduced the call to
libxl_get_physinfo() that is failing, happened on Xen 4.3, but I'm sure
I tested it with 4.2 a couple of times, and I don't see why it wouldn't
work there...

If you tell me the precise version of the distro you're using I'll see
if I can give it a try.

Regards,
Dario

--
<<This happens because I choose it to happen!>> (Raistlin Majere)
-----------------------------------------------------------------
Dario Faggioli, Ph.D, http://about.me/dario.faggioli
Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]