[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] kvm/libvirt can't use vmdk files? qemu: 'vmdk' invalid format



Dear All, 

While trying to run kvm VM using vmdk disk on 6.4 , I got into the following error,

error: Failed to create domain from vmdkvm.xml
error: internal error process exited while connecting to monitor: qemu-kvm: -drive file=/mnt/vmdkTOKVM/vmdkTOKVM.vmdk,if=none,id=drive-ide0-0-0,format=vmdk,cache=none: 'vmdk' invalid format

upon further digging I came across this thread (https://www.redhat.com/archives/libvirt-users/2011-November/msg00044.html

also qemu-kvm shows that vmdk is supported but all in vain

Even if I try running with command line instead of XML I get error though it says it is supported
 
[root vmdkTOKVM]# /usr/libexec/qemu-kvm -drive file=/mnt/vmdkTOKVM/vmdkTOKVM.vmdk,format=?
Supported formats: raw cow qcow vdi vmdk cloop dmg bochs vpc vvfat qcow2 qed parallels nbd blkdebug host_cdrom host_floppy host_device file
 
[root vmdkTOKVM]# /usr/libexec/qemu-kvm -drive file=/mnt/vmdkTOKVM/vmdkTOKVM.vmdk,format=vmdk
qemu-kvm: -drive file=/mnt/XOcom-prx-kvm/XOcom-prx-kvm.vmdk,format=vmdk: 'vmdk' invalid format


The packages being used are:

qemu-img-0.12.1.2-2.355.0.1.el6_4.9.x86_64
qemu-kvm-0.12.1.2-2.355.0.1.el6_4.9.x86_64
qemu-kvm-tools-0.12.1.2-2.355.0.1.el6_4.9.x86_64
libvirt-0.10.2-18.el6_4.14.x86_64


Any help in this regard will highly be apprectiated.

Thank you

Hammad Siddqi

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]