[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Installing tcp/ssh drivers for libvirt



Hi Eric,

I'm trying to install the drivers on XenServer 6.0.2 and on Centos 5.2/6.4.  I downloaded libvirt 1.1.3.  So, if I try to configure w/ xen and libxl, the configure script errors out saying -

configure: error: You must install the libxl Library from Xen >= 4.2 to compile libxenlight driver with -lxl

btw, I am trying to compile this on XenServer6.0.2 itself, and plan to use virsh on the Centos 5.2/6.4 running on it.  

Any guidance you could provide, on how to go about this?

Regards,
Shiva




On Tue, Oct 29, 2013 at 1:09 PM, Eric Blake <eblake redhat com> wrote:
On 10/29/2013 11:03 AM, Shiva Bhanujan wrote:
> Hello,
>
> Can somebody please point me to documentation regarding installing libvirt
> and the associated drivers from .rpms?

You didn't tell us what distro you are using.  There's plenty of rpms,
but without that detail, we can't tell you which ones to use.

>
> If there were a yum repository where I could download the daemon and the
> drives, that'd be great?  Any advice would be appreciated.

In the Fedora distro, the daemon is already part of the main Fedora
repository.  You can also use the fedora-virt-preview repo to use the
latest virt stack while still sticking to a stable release (ie. right
now, that provides rawhide's libvirt 1.1.3 on top of Fedora 19, instead
of being stuck at 1.0.5).

http://fedoraproject.org/wiki/Virtualization_Preview_Repository

If you are using something like RHEL, then contact your vendor.  If you
are using something like CentOS, then you get to enjoy the consequences
of a distro with no formal support.

--
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]