[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Libvirt Live Migration



I tired to install newer version of qemu-kvm (2.1.0-2.9-x86_64) through rpms but the following rpms are not all available

- qemu-2.1.0-2.9-x86_64.rpm
- qemu-kvm-2.1.0-2.9-x86_64.rpm
- qemu-common-2.1.0-2.9-x86_64.rpm
- qemu-kvm-tools-2.1.0-2.9-x86_64.rpm
- qemu-debuginfo-2.1.0-2.9-x86_64.rpm
- qemu-system-x86-2.1.0-2.9-x86_64.rpm
- qemu-guest-agent-2.1.0-2.9-x86_64.rpm
- qemu-user-2.1.0-2.9-x86_64.rpm
- qemu-img-2.1.0-2.9-x86_64.rpm 

So I changed from Centos 6.6 to Ubuntu 14.04 because the environment setup is much easier, some bugs had been fixed but the migration did not work at all
and I got this error message "error: internal error: unable to execute QEMU command 'drive-mirror': Failed to connect to socket: Invalid argument"
I thought it's security issue so I disabled the SELINUX and I make some firwall configuration but the problem persist: 
<<
 sudo iptables -A INPUT -p tcp -m multiport --ports 16509 -m comment --comment "libvirt" -j ACCEPT
 sudo iptables -A INPUT -p tcp -m multiport --ports 49152:49216 -m comment --comment "migration" -j ACCEPT
>>
 Have you any idea what is the reason behind this problem??

On 24 November 2014 at 11:32, Dhia Abbassi <dhia absi gmail com> wrote:
I will try a newer version.

On 24 November 2014 at 11:30, Michal Privoznik <mprivozn redhat com> wrote:
On 24.11.2014 11:23, Dhia Abbassi wrote:
Thanks for your answer,

1) In this case i'm not using shared storage, the migration is happening
between two non-shared storage with full disk copy
2) I already created the file with same size, and the vm
works properly after a restart, my problem that it remains paused and I
can't resume it until it's rebooted.
3) I'm using qemu-kvm 1.0

This may be the root of problem. That's nearly 3 years old qemu.

Michal



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]