[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] [libvirt] libvirt 1.2.4 and virt-manager 0.9.0 are not incompatible



Hi,

 

You need to update libvirt-python:

 

http://libvirt.org/sources/python/

 

 

From: libvir-list-bounces redhat com [mailto:libvir-list-bounces redhat com] On Behalf Of xeon_feng
Sent: Tuesday, May 06, 2014 2:00 PM
To: libvirt-users redhat com; libvir-list redhat com
Subject: [libvirt] libvirt 1.2.4 and virt-manager 0.9.0 are not incompatible

 

Hello everyone

 

    I encountered a problem when I completed the update of libvirt from 0.10 to 1.2.4 .  

    The problem was that  virt-manager(version 0.9.0) could not start and reported error : "ImportError:  /usr/lib64/libvirt.so.0: version 'LIBVIRT_PRIVIATE_0.10.2' not found (required by /usr/lib64/python2.6/site-packages/libvirtmod.so)".

    I found the libvirt.so.0 link file just in the /usr/lib64/ directory , but it was linking  to  libvirt.so.0.1002.4 .not to the libvirt.so.0.10.2 

    I made libvirt.so.0 to link to  libvirt.so.0.10.2 and restarted virt-manager , virt-manager started normally  then  restarted libvirtd  failure, reporting error:l “ibvirtd: /usr/lib64/libvirt.so.0: version 'LIBVIRT_1.2.3' not found (require by libvirtd) .....” 

    I made   libvirt.so.0 to link to  libvirt.so.0.1002.4  and  restart libvirtd , libvirtd started normally  again.

    

    Please help me to resolve the problem and give me some advise....  

    Thanks a lot..

 

                                                                                                                        Xeon.Feng    


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]