[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] Need help with [virt net-create]



Is it possible to configure 2 virtual nics in the same ip range ?

Here is what I am trying.
   
**** This works ****************
cat nw1.xml
<network>
  <name>nw1</name>
  <domain name='nw1' />
  <forward mode='nat' dev='eth2'/>
  <ip address='192.168.101.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.101.128' end='192.168.101.254'/>
    </dhcp>
  </ip>
</network>


[root localhost nw]# virsh net-create nw1.xml
Network nw1 created from nw1.xml

[root localhost nw]# virsh net-list --all
 Name                 State      Autostart     Persistent
----------------------------------------------------------
 nw1                  active     no            no
 default              active     yes           yes



****** FAILS when given the same ip address range of an existing virtual interface *******
[root localhost nw]# cat nw2.xml
<network>
  <name>nw2</name>
  <domain name='nw2' />
  <forward mode='nat' dev='eth2'/>
  <ip address='192.168.101.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.101.128' end='192.168.101.254'/>
    </dhcp>
  </ip>
</network>

[root localhost nw]# virsh net-create nw2.xml
error: Failed to create network from nw2.xml
error: internal error: Network is already in use by interface virbr1



****** PASS - on giving diff ip range *******
[root localhost nw]# cat nw3.xml
<network>
  <name>nw3</name>
  <domain name='nw3' />
  <forward mode='nat' dev='eth2'/>
  <ip address='192.168.102.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.102.128' end='192.168.102.254'/>
    </dhcp>
  </ip>
</network>


[root localhost nw]# virsh net-create nw3.xml
Network nw3 created from nw3.xml

[root localhost nw]# virsh net-list --all
 Name                 State      Autostart     Persistent
----------------------------------------------------------
 nw1                  active     no            no
 nw3                  active     no            no
 default              active     yes           yes



Any suggestions on what could be wrong here ? 



Thanks,
G




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]