[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Migrate Win2k3 to KVM


Thanks for your prompt answer!

I don't know the format of the image. It was made by CloneZilla. Is that then a raw image?

Of course I can post the XML of the VM config.

I tried out all of the possibilities: IDE, SATA, SCSI and Virtio.
The image was taken from a SATA hardware which is a normal Intel chipset. (I can check
the real machine again, if it is important).

I don't know whether the image booting or not. :-( How can I check it? The boot process is
working because I can see the BSOD screen and the no system disk error message.

Any ideas would be appreciated!


2015-07-11 17:40 GMT+02:00 Jeff Tchang <jeff tchang gmail com>:
- What format is the image is?
- Can you post an XML file of the VM config?

Changing the driver to VirtIO via registry edits may exacerbate the problem. I've never done this but wouldn't it make sense to stick to the more supported IDE drive emulation until you get it booted and thus remove possible variables of it not booting?

Are you able to boot the image any other way?

On Sat, Jul 11, 2015 at 8:28 AM, Ruzsinszky Attila <ruzsinszky attila gmail com> wrote:

I made a disk image with CloneZilla from the original physical machine.

That image was restored on an iSCSI volume.
It isn't booting. I got BSOD.
I tried IDE, SATA, SCSI disk type without any success.
I tried to using virtio driver and if I use my image+W2k3 install CD+virtio VFD the Windows repair console see the disk and I can use the repair console with my image but the windows not start
(or not booting because the system disk can't be seen by original "registry").

The drivers from virtio VFD image were copied to Windows' Driver directory manually.

I tried to use virt-win-reg:
rattila amd1:~$ virt-win-reg SJ-SIMISPC
/dev/disk/by-path/<iSCSI-path>:simispc-lun-2: Engedély megtagadva at /usr/bin/virt-win-reg line 260.
(it means: Permission denied.)

What can I do changing the original driver to virtio (or IDE/SATA/SCSI in KVM)?

I can't do anything with the physical machine so the only option is playing with the disk image.


libvirt-users mailing list
libvirt-users redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]