[libvirt-users] Unable to start sandbox: Kernel module dir /lib/modules/3.18.5-x86_64-linode52/kernel does not exist

Adam Smith adamsmth088 at gmail.com
Sat Mar 7 03:38:16 UTC 2015

Dear all,

I have been trying to set up the set up Libvirt Sandbox without success.

I want to use virt-sandbox in order to run untrusted programs in a secure
environment. I am had no knowledge about virtualization until a couple of
days ago, so I am probably doing something wrong.

The scenario is the following:
Linode instance. OS that I have tried: Ubuntu 14.04, Ubuntu 14, Fedora 21.
Both compiling from source and installing the pre-compiled packages. But I
always reach the same error:


$ virt-sandbox -c qemu:///session  /bin/date

Unable to start sandbox: Kernel module dir
/lib/modules/3.18.5-x86_64-linode52/kernel does not exist


I have been told by the guys of Linode that:

"The kernels we use are completely compiled and do not utilize modules. In
addition, the kernels are loaded from the host rather than the /boot

Any hints to solve this issue? Is the only solution to compile my own

Also, if I decide to use a service like Linode, AWS, Digital Ocean...then
the server that I would be using would be already a virtual server. Is it a
problem to run virt-sandbox within a server which is already a virtual

Thanks a lot!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20150306/94ddbeae/attachment.htm>

More information about the libvirt-users mailing list